accumulo-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Josh Elser (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (ACCUMULO-3662) Verify correct looking JAVA_HOME in build_native_library.sh
Date Tue, 17 Mar 2015 17:27:39 GMT

    [ https://issues.apache.org/jira/browse/ACCUMULO-3662?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14365587#comment-14365587
] 

Josh Elser commented on ACCUMULO-3662:
--------------------------------------

I believe root just didn't have JAVA_HOME set and that was enough to cause it (Accumulo running
as an 'accumulo' user).

> Verify correct looking JAVA_HOME in build_native_library.sh
> -----------------------------------------------------------
>
>                 Key: ACCUMULO-3662
>                 URL: https://issues.apache.org/jira/browse/ACCUMULO-3662
>             Project: Accumulo
>          Issue Type: Improvement
>          Components: scripts
>            Reporter: Josh Elser
>            Priority: Critical
>              Labels: newbie, usability
>             Fix For: 1.7.0, 1.6.3
>
>
> JAVA_HOME needs to be set to a valid JDK to run {{build_native_library.sh}} successfully.
Either it's extracted from the environment or it's set in accumulo-env.sh.
> Either way, when it isn't set (or set incorrectly), we should catch this, print a warning
and exit the script to prevent the deluge 'JNI_EXPORT' related error messages.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message