accumulo-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Josh Elser (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (ACCUMULO-3611) Unable to enter password that contains a '!' in shell
Date Mon, 23 Feb 2015 01:49:12 GMT

    [ https://issues.apache.org/jira/browse/ACCUMULO-3611?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14332477#comment-14332477
] 

Josh Elser commented on ACCUMULO-3611:
--------------------------------------

For the context of a command that makes sense, but not for entering a password.

> Unable to enter password that contains a '!' in shell
> -----------------------------------------------------
>
>                 Key: ACCUMULO-3611
>                 URL: https://issues.apache.org/jira/browse/ACCUMULO-3611
>             Project: Accumulo
>          Issue Type: Bug
>          Components: shell
>            Reporter: Josh Elser
>
> 'msknapp' reported a problem on [Stackoverflow|http://stackoverflow.com/questions/28399361/thriftsecurityexception-userroot-codebad-credentials]:
> {quote}
> I changed my password to a simple one, updated the site file, and it worked. I tried
changing it back but it would not let me create a password with an exclamation mark in it,
accumulo produces an exception saying the event was not found. When you initially create the
root user though, you can get away with an exclamation mark in your password, which is how
I got in that situation.
> {quote}
> Might be a bug in JLine which we need to look into. We need to make sure that we're not
limiting the characters that can be used in user passwords.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message