accumulo-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Josh Elser (JIRA)" <j...@apache.org>
Subject [jira] [Assigned] (ACCUMULO-3537) Create an explicit configuration option for replacing relative paths
Date Tue, 27 Jan 2015 18:56:35 GMT

     [ https://issues.apache.org/jira/browse/ACCUMULO-3537?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Josh Elser reassigned ACCUMULO-3537:
------------------------------------

    Assignee: Josh Elser

> Create an explicit configuration option for replacing relative paths
> --------------------------------------------------------------------
>
>                 Key: ACCUMULO-3537
>                 URL: https://issues.apache.org/jira/browse/ACCUMULO-3537
>             Project: Accumulo
>          Issue Type: Sub-task
>            Reporter: Christopher Tubbs
>            Assignee: Josh Elser
>             Fix For: 1.7.0
>
>
> {{instance.dfs.uri}} and {{instance.dfs.dir}} were deprecated in as part of ACCUMULO-2061,
and were superseded by {{instance.volumes}}.
> This was a little bit confusing, because users upgrading from previous versions would
still have relative paths in their metadata. To interpret these relative paths, these deprecated
properties must still be set. So, it's a bit confusing to have deprecated properties which
are still required for functionality.
> What we should do is explicitly create a way to replace these entries with absolute paths
that does not depend on using deprecated properties.
> A sensible location for this is {{instance.volumes.replacements}}. This field could have
a special replacement, "RELATIVE", which replaces all relative paths with an explicit target
volume. ACCUMULO-3007 ignored relative paths, but this issue proposes to handle them instead
of ignore them.
> These properties previously provided two functions:
> # Create new files with absolute paths (only if instance.volumes is not set)
> # Interpret old relative files (always)
> The first function is replaced with {{instance.volumes}}. The second function is replaced
by the proposed improvement to {{instance.volumes.replacements}} here.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message