accumulo-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Christopher Tubbs (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (ACCUMULO-2641) scan id not set in org.apache.accumulo.core.client.admin.ActiveScan
Date Thu, 15 Jan 2015 19:23:34 GMT

     [ https://issues.apache.org/jira/browse/ACCUMULO-2641?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Christopher Tubbs updated ACCUMULO-2641:
----------------------------------------
    Resolution: Fixed
        Status: Resolved  (was: Patch Available)

> scan id not set in org.apache.accumulo.core.client.admin.ActiveScan
> -------------------------------------------------------------------
>
>                 Key: ACCUMULO-2641
>                 URL: https://issues.apache.org/jira/browse/ACCUMULO-2641
>             Project: Accumulo
>          Issue Type: Bug
>          Components: client
>    Affects Versions: 1.4.4, 1.5.1
>            Reporter: Ed Coleman
>            Assignee: Ed Coleman
>            Priority: Blocker
>             Fix For: 1.6.2, 1.7.0
>
>         Attachments: ACCUMULO-2641.patch
>
>          Time Spent: 40m
>  Remaining Estimate: 0h
>
> Trying to profile some long running scans I tried to use the getScanid() method on ActiveScan,
but it always returned 0.
> Looking at the class, it seems that the value is never set.  There is a getter but no
setter and it is not set in the constructor.
> Also, it seems that the scanid is not included in the thrift ActiveScan so a fix will
not be a simple as just setting scanid in the constructor.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message