accumulo-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Christopher Tubbs (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (ACCUMULO-2641) scan id not set in org.apache.accumulo.core.client.admin.ActiveScan
Date Thu, 08 Jan 2015 16:22:35 GMT

    [ https://issues.apache.org/jira/browse/ACCUMULO-2641?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14269500#comment-14269500
] 

Christopher Tubbs commented on ACCUMULO-2641:
---------------------------------------------

Okay, so yes, I see that ACCUMULO-3433 expresses my concerns. I hadn't actually checked whether
the build itself was failing or not. Even if it passed, the reproducibility problem is an
issue. We can move the conversation to that issue, as it seems separate from this one.

> scan id not set in org.apache.accumulo.core.client.admin.ActiveScan
> -------------------------------------------------------------------
>
>                 Key: ACCUMULO-2641
>                 URL: https://issues.apache.org/jira/browse/ACCUMULO-2641
>             Project: Accumulo
>          Issue Type: Bug
>          Components: client
>    Affects Versions: 1.4.4, 1.5.1
>            Reporter: Ed Coleman
>            Assignee: Ed Coleman
>            Priority: Blocker
>             Fix For: 1.6.2, 1.7.0
>
>         Attachments: ACCUMULO-2641.patch
>
>          Time Spent: 40m
>  Remaining Estimate: 0h
>
> Trying to profile some long running scans I tried to use the getScanid() method on ActiveScan,
but it always returned 0.
> Looking at the class, it seems that the value is never set.  There is a getter but no
setter and it is not set in the constructor.
> Also, it seems that the scanid is not included in the thrift ActiveScan so a fix will
not be a simple as just setting scanid in the constructor.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message