accumulo-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Corey J. Nolet (JIRA)" <j...@apache.org>
Subject [jira] [Comment Edited] (ACCUMULO-2641) scan id not set in org.apache.accumulo.core.client.admin.ActiveScan
Date Thu, 08 Jan 2015 16:16:35 GMT

    [ https://issues.apache.org/jira/browse/ACCUMULO-2641?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14269491#comment-14269491
] 

Corey J. Nolet edited comment on ACCUMULO-2641 at 1/8/15 4:16 PM:
------------------------------------------------------------------

As far as I can tell, the only change was the addition of the serialVersionUuid? I did just
notice that I clobbered a comment in the ActiveScan class that explains it but that's going
to be clobbered anyways. I've been battling with this for awhile whenever the thrift profile
has run- I'm not sure if this problem was just introduced in this ticket. It's one of the
reasons I created ACCUMULO-3433. Last time i ran the thrift profile, I ran into the issue
where the build failed as a result of the files being regenerated.


was (Author: sonixbp):
As far as I can tell, the only change was the addition of the serialVersionUuid? I did just
notice that I clobbered a comment in the ActiveScan class that explains it but that's going
to be clobbered anyways. I've been battling with this for awhile whenever the thrift profile
has run- I'm not sure if this problem was just introduced in this ticket. It's one of the
reasons I created ACCUMULO-3002. Last time i ran the thrift profile, I ran into the issue
where the build failed as a result of the files being regenerated.

> scan id not set in org.apache.accumulo.core.client.admin.ActiveScan
> -------------------------------------------------------------------
>
>                 Key: ACCUMULO-2641
>                 URL: https://issues.apache.org/jira/browse/ACCUMULO-2641
>             Project: Accumulo
>          Issue Type: Bug
>          Components: client
>    Affects Versions: 1.4.4, 1.5.1
>            Reporter: Ed Coleman
>            Assignee: Ed Coleman
>            Priority: Blocker
>             Fix For: 1.6.2, 1.7.0
>
>         Attachments: ACCUMULO-2641.patch
>
>          Time Spent: 40m
>  Remaining Estimate: 0h
>
> Trying to profile some long running scans I tried to use the getScanid() method on ActiveScan,
but it always returned 0.
> Looking at the class, it seems that the value is never set.  There is a getter but no
setter and it is not set in the constructor.
> Also, it seems that the scanid is not included in the thrift ActiveScan so a fix will
not be a simple as just setting scanid in the constructor.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message