accumulo-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Christopher Tubbs (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (ACCUMULO-3394) Break out inner classes TServerUtils
Date Tue, 09 Dec 2014 04:43:12 GMT

    [ https://issues.apache.org/jira/browse/ACCUMULO-3394?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14238971#comment-14238971
] 

Christopher Tubbs commented on ACCUMULO-3394:
---------------------------------------------

This is a reasonable reorganization of some server-side utilities related to our RPC services.
However, I would strongly prefer a different package name than {{thrift}}, which is a package
name we typically use for generated thrift code. Is there a more appropriate package name
that will be less likely to be confused with those we use for generated thrift code? If not,
that's fine, too. I'll just have to improve my {{grep -v /thrift/}} pattern when I'm spelunking
through our code. Maybe {{org.apache.accumulo.server.util.rpc}}?

> Break out inner classes TServerUtils
> ------------------------------------
>
>                 Key: ACCUMULO-3394
>                 URL: https://issues.apache.org/jira/browse/ACCUMULO-3394
>             Project: Accumulo
>          Issue Type: Improvement
>          Components: rpc
>            Reporter: Josh Elser
>            Assignee: Josh Elser
>            Priority: Minor
>             Fix For: 1.7.0
>
>          Time Spent: 40m
>  Remaining Estimate: 0h
>
> Lots of inner classes floating around in TServerUtils which could really be consolidated
into a thrift package inside of server-base.
> Would reduce the overall size of TServerUtils and make things a bit more consumable.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message