accumulo-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Billie Rinaldi (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (ACCUMULO-2981) Cease use of underscore "_" as an identifier
Date Mon, 15 Dec 2014 18:33:13 GMT

     [ https://issues.apache.org/jira/browse/ACCUMULO-2981?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Billie Rinaldi updated ACCUMULO-2981:
-------------------------------------
    Description: 
JDK 8 adds a new warning that the use of underscore as an identifier may be removed in future
versions. We should just go ahead and remove the use of these in our code to eliminate these
warnings and prepare for future versions of Java where support for this is dropped.

Also fix a type safety check of a generic method which prevents compilation on JDK8, and make
JDK version configurable in the POM to make it easier to run a test build against 1.8.

  was:JDK 8 adds a new warning that the use of underscore as an identifier may be removed
in future versions. We should just go ahead and remove the use of these in our code to eliminate
these warnings and prepare for future versions of Java where support for this is dropped.


> Cease use of underscore "_" as an identifier
> --------------------------------------------
>
>                 Key: ACCUMULO-2981
>                 URL: https://issues.apache.org/jira/browse/ACCUMULO-2981
>             Project: Accumulo
>          Issue Type: Sub-task
>            Reporter: Christopher Tubbs
>            Assignee: Christopher Tubbs
>              Labels: newbie
>             Fix For: 1.6.2, 1.7.0
>
>          Time Spent: 20m
>  Remaining Estimate: 0h
>
> JDK 8 adds a new warning that the use of underscore as an identifier may be removed in
future versions. We should just go ahead and remove the use of these in our code to eliminate
these warnings and prepare for future versions of Java where support for this is dropped.
> Also fix a type safety check of a generic method which prevents compilation on JDK8,
and make JDK version configurable in the POM to make it easier to run a test build against
1.8.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message