accumulo-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "David Medinets (JIRA)" <>
Subject [jira] [Commented] (ACCUMULO-2981) Cease use of underscore "_" as an identifier
Date Sun, 14 Dec 2014 02:23:13 GMT


David Medinets commented on ACCUMULO-2981:

I didn't know about change in Java 8. It's annoying because I don't particularly like camelCaseVariableNames.
I find it hard to read sometimes and like using really_long_names_occasionally in my code.
Maybe Java 9 will coincide with my retirement and I won't need to change my code. :)

> Cease use of underscore "_" as an identifier
> --------------------------------------------
>                 Key: ACCUMULO-2981
>                 URL:
>             Project: Accumulo
>          Issue Type: Sub-task
>            Reporter: Christopher Tubbs
>            Assignee: Christopher Tubbs
>              Labels: newbie
>             Fix For: 1.6.2, 1.7.0
>          Time Spent: 20m
>  Remaining Estimate: 0h
> JDK 8 adds a new warning that the use of underscore as an identifier may be removed in
future versions. We should just go ahead and remove the use of these in our code to eliminate
these warnings and prepare for future versions of Java where support for this is dropped.

This message was sent by Atlassian JIRA

View raw message