accumulo-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Josh Elser (JIRA)" <j...@apache.org>
Subject [jira] [Reopened] (ACCUMULO-80) Refactor ScannerOptions to just use a map of iterators
Date Wed, 17 Dec 2014 04:07:14 GMT

     [ https://issues.apache.org/jira/browse/ACCUMULO-80?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Josh Elser reopened ACCUMULO-80:
--------------------------------

> Refactor ScannerOptions to just use a map of iterators
> ------------------------------------------------------
>
>                 Key: ACCUMULO-80
>                 URL: https://issues.apache.org/jira/browse/ACCUMULO-80
>             Project: Accumulo
>          Issue Type: Improvement
>          Components: client, tserver
>            Reporter: Jesse Yates
>
> Based on comments in ACCUMULO-53 ScannerOptions should be refactored to just having a
Map<String, IteratorSetting> mapping iterator names to iterator settings, instead of
a list and a map<scope, options>. This makes it really easy for people to add/remove
iterators.
> This involves a change to the thrift interface as well as in ScannerBase and the server
side reading of the map. 



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message