accumulo-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Johannes Bauer (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (ACCUMULO-3313) Classpath for starting zookeper is almost empty
Date Fri, 07 Nov 2014 12:55:33 GMT

     [ https://issues.apache.org/jira/browse/ACCUMULO-3313?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Johannes Bauer updated ACCUMULO-3313:
-------------------------------------
    Description: 
When I run the MiniAccumuloCluster 1.6.0 on Windows, it does not start up correctly, but ends
up with the error

{code}
java.lang.RuntimeException: Zookeeper did not start within 20 seconds. Check the logs in C:\Users\jsbaue\AppData\Local\Temp\1415364318664-0\logs
for errors.  Last exception: java.net.ConnectException: Connection refused: connect
	at org.apache.accumulo.minicluster.impl.MiniAccumuloClusterImpl.start(MiniAccumuloClusterImpl.java:460)
	at org.apache.accumulo.minicluster.MiniAccumuloCluster.start(MiniAccumuloCluster.java:72)
	at com.gfk.st2.pace.datafactory.adaptor.accumulo.impl.MiniAccumuloClusterTest.testStart(MiniAccumuloClusterTest.java:50)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
{code}

Reason is, that Zookeeper does not startup at all, as the classpath, returned by the function
{code}
private String getClasspath() throws IOException
{code}
in MiniAccumuloClusterImpl.java returns a classpath, containing just the config directory.
The reason for this is the part 


> Classpath for starting zookeper is almost empty
> -----------------------------------------------
>
>                 Key: ACCUMULO-3313
>                 URL: https://issues.apache.org/jira/browse/ACCUMULO-3313
>             Project: Accumulo
>          Issue Type: Bug
>          Components: mini
>         Environment: Windows
> Hadoop 2.5.0cdh5.2.0
> Accumulo 1.6.0cdh5.1.0
>            Reporter: Johannes Bauer
>         Attachments: screenshot-1.png
>
>
> When I run the MiniAccumuloCluster 1.6.0 on Windows, it does not start up correctly,
but ends up with the error
> {code}
> java.lang.RuntimeException: Zookeeper did not start within 20 seconds. Check the logs
in C:\Users\jsbaue\AppData\Local\Temp\1415364318664-0\logs for errors.  Last exception: java.net.ConnectException:
Connection refused: connect
> 	at org.apache.accumulo.minicluster.impl.MiniAccumuloClusterImpl.start(MiniAccumuloClusterImpl.java:460)
> 	at org.apache.accumulo.minicluster.MiniAccumuloCluster.start(MiniAccumuloCluster.java:72)
> 	at com.gfk.st2.pace.datafactory.adaptor.accumulo.impl.MiniAccumuloClusterTest.testStart(MiniAccumuloClusterTest.java:50)
> 	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
> 	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
> {code}
> Reason is, that Zookeeper does not startup at all, as the classpath, returned by the
function
> {code}
> private String getClasspath() throws IOException
> {code}
> in MiniAccumuloClusterImpl.java returns a classpath, containing just the config directory.
The reason for this is the part 



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message