accumulo-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Josh Elser (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (ACCUMULO-3299) Some build tests are misnamed
Date Sat, 22 Nov 2014 05:16:34 GMT

    [ https://issues.apache.org/jira/browse/ACCUMULO-3299?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14221811#comment-14221811
] 

Josh Elser commented on ACCUMULO-3299:
--------------------------------------

KeyValueEqualityTest and StatusCombinerMacTest were both intentional but stem from the fact
that *most* of our ITs set up MAC. I don't care if you feel the need to change them to be
ITs instead, just letting you know that they were intentionally named as such.

> Some build tests are misnamed
> -----------------------------
>
>                 Key: ACCUMULO-3299
>                 URL: https://issues.apache.org/jira/browse/ACCUMULO-3299
>             Project: Accumulo
>          Issue Type: Bug
>          Components: build
>            Reporter: Christopher Tubbs
>            Assignee: Christopher Tubbs
>             Fix For: 1.7.0
>
>          Time Spent: 10m
>  Remaining Estimate: 0h
>
> I was looking at some of the tests and found two tests which don't run, because their
names don't match a surefire or failsafe plugin filename pattern. These are {{MetadataMaxFiles}}
and {{UnusedWalDoesntCloseReplicationStatus}}. Both appear that they should be named such
that they end in *IT*.
> In addition, I found two classes which are unit tests, but extend an integration test.
That also seems in error. These are {{KeyValueEqualityTest}} and {{StatusCombinerMacTest}}.
These probably should end in *IT* instead of *Test*.
> These issues exist in the 1.7.0-SNAPSHOT (master) branch. I have not checked other development
branches for similar errors.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message