accumulo-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Josh Elser (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (ACCUMULO-3252) SslITs OOME tserver on master
Date Wed, 12 Nov 2014 21:18:34 GMT

    [ https://issues.apache.org/jira/browse/ACCUMULO-3252?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14208715#comment-14208715
] 

Josh Elser commented on ACCUMULO-3252:
--------------------------------------

Added some debug and got some stack traces:

{noformat}
2014-11-12 13:17:28,464 [util.SslConnectionParams] INFO : SSL not enabled
java.lang.Exception
	at org.apache.accumulo.core.util.SslConnectionParams.forConfig(SslConnectionParams.java:55)
	at org.apache.accumulo.core.util.SslConnectionParams.forClient(SslConnectionParams.java:137)
	at org.apache.accumulo.core.util.ThriftUtil.getClient(ThriftUtil.java:121)
	at org.apache.accumulo.core.util.ThriftUtil.getTServerClient(ThriftUtil.java:138)
	at org.apache.accumulo.core.client.impl.ThriftScanner.getBatchFromServer(ThriftScanner.java:90)
	at org.apache.accumulo.core.metadata.MetadataLocationObtainer.lookupTablet(MetadataLocationObtainer.java:103)
	at org.apache.accumulo.core.client.impl.TabletLocatorImpl.lookupTabletLocation(TabletLocatorImpl.java:465)
	at org.apache.accumulo.core.client.impl.TabletLocatorImpl._locateTablet(TabletLocatorImpl.java:622)
	at org.apache.accumulo.core.client.impl.TabletLocatorImpl.locateTablet(TabletLocatorImpl.java:440)
	at org.apache.accumulo.core.client.impl.Writer.update(Writer.java:91)
	at org.apache.accumulo.server.util.MetadataTableUtil.update(MetadataTableUtil.java:148)
	at org.apache.accumulo.server.util.MetadataTableUtil.update(MetadataTableUtil.java:140)
	at org.apache.accumulo.server.util.MetadataTableUtil.addTablet(MetadataTableUtil.java:206)
	at org.apache.accumulo.master.tableOps.PopulateMetadata.call(CreateTable.java:120)
	at org.apache.accumulo.master.tableOps.MasterRepo.call(MasterRepo.java:1)
	at org.apache.accumulo.master.tableOps.TraceRepo.call(TraceRepo.java:57)
	at org.apache.accumulo.fate.Fate$TransactionRunner.run(Fate.java:67)
	at org.apache.accumulo.fate.util.LoggingRunnable.run(LoggingRunnable.java:34)
	at java.lang.Thread.run(Thread.java:745)
2014-11-12 13:17:28,555 [fate.Fate] ERROR: Thread "Repo runner 0" died Java heap space
java.lang.OutOfMemoryError: Java heap space
2014-11-12 13:17:28,770 [util.SslConnectionParams] INFO : SSL not enabled
java.lang.Exception
	at org.apache.accumulo.core.util.SslConnectionParams.forConfig(SslConnectionParams.java:55)
	at org.apache.accumulo.core.util.SslConnectionParams.forClient(SslConnectionParams.java:137)
	at org.apache.accumulo.core.util.ThriftUtil.getClient(ThriftUtil.java:121)
	at org.apache.accumulo.core.util.ThriftUtil.getTServerClient(ThriftUtil.java:138)
	at org.apache.accumulo.core.client.impl.TabletServerBatchReaderIterator.doLookup(TabletServerBatchReaderIterator.java:620)
	at org.apache.accumulo.core.client.impl.TabletServerBatchReaderIterator$QueryTask.run(TabletServerBatchReaderIterator.java:346)
	at org.apache.accumulo.core.trace.wrappers.TraceRunnable.run(TraceRunnable.java:57)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
	at org.apache.accumulo.core.trace.wrappers.TraceRunnable.run(TraceRunnable.java:57)
	at org.apache.accumulo.core.util.LoggingRunnable.run(LoggingRunnable.java:34)
	at java.lang.Thread.run(Thread.java:745)
{noformat}

> SslITs OOME tserver on master
> -----------------------------
>
>                 Key: ACCUMULO-3252
>                 URL: https://issues.apache.org/jira/browse/ACCUMULO-3252
>             Project: Accumulo
>          Issue Type: Bug
>            Reporter: Josh Elser
>            Priority: Blocker
>             Fix For: 1.7.0
>
>
> I think something is broken with SSL in 1.7. For a week and a half or so, I've been seeing
SslIT and SslWithClientAuthIT fail occasionally because a server process failed due to an
OOME.
> I haven't seen it on 1.6 and the brief poking around and bisect has not been fruitful
in actually reproducing the issue.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message