accumulo-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Josh Elser (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (ACCUMULO-3252) SslITs OOME tserver on master
Date Wed, 29 Oct 2014 17:58:35 GMT

    [ https://issues.apache.org/jira/browse/ACCUMULO-3252?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14188686#comment-14188686
] 

Josh Elser commented on ACCUMULO-3252:
--------------------------------------

I haven't a clue. I think I tried tripling the memory of the master at one point and re-running
the test and that didn't help.

Some other observations is that when you have a client with a mismatch of SSL (client using
SSL and servers not, or vice versa), the client will eventually OOME because it's in some
tight failure loop. It's possible the same thing is happening server-side? I haven't had the
time to dig into it.

> SslITs OOME tserver on master
> -----------------------------
>
>                 Key: ACCUMULO-3252
>                 URL: https://issues.apache.org/jira/browse/ACCUMULO-3252
>             Project: Accumulo
>          Issue Type: Bug
>            Reporter: Josh Elser
>            Priority: Blocker
>             Fix For: 1.7.0
>
>
> I think something is broken with SSL in 1.7. For a week and a half or so, I've been seeing
SslIT and SslWithClientAuthIT fail occasionally because a server process failed due to an
OOME.
> I haven't seen it on 1.6 and the brief poking around and bisect has not been fruitful
in actually reproducing the issue.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message