accumulo-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Josh Elser (JIRA)" <j...@apache.org>
Subject [jira] [Created] (ACCUMULO-3216) VolumeManagerImpl.findMatchingFilesystem is lacking
Date Thu, 09 Oct 2014 19:18:34 GMT
Josh Elser created ACCUMULO-3216:
------------------------------------

             Summary: VolumeManagerImpl.findMatchingFilesystem is lacking
                 Key: ACCUMULO-3216
                 URL: https://issues.apache.org/jira/browse/ACCUMULO-3216
             Project: Accumulo
          Issue Type: Bug
          Components: tserver
    Affects Versions: 1.6.1
            Reporter: Josh Elser
            Priority: Critical
             Fix For: 1.6.2, 1.7.0


Part of the problem found in ACCUMULO-3215

On a standalone instance, I configured accumulo-site with

  <property>
    <name>instance.volumes</name>
    <value>hdfs://localhost:8020/accumulo1.6.2</value>
  </property>

But in core-site.xml

    <property>
        <name>fs.defaultFS</name>
        <value>hdfs://127.0.0.1:8020</value>
    </property>

I then tried to export a table and re-import it (essentially followed http://accumulo.apache.org/1.5/examples/export.html)

Ultimately, in the fate op for import table, we tried to find the matching filesystem for
127.0.0.1:8020 out of choices: localhost:8020. This then threw an NPE because there are no
matching options. Which is a really nasty issue...

We could try to make things a little better by converting any URIs with IP addrs as the hostname
component to resolved the resolved hostname via DNS, but we should already know that relying
on rDNS to be properly configured is a shot in the dark at best.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message