accumulo-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Josh Elser (JIRA)" <j...@apache.org>
Subject [jira] [Comment Edited] (ACCUMULO-3214) NPE checking if replication is enabled during tablet assignment
Date Wed, 08 Oct 2014 21:35:34 GMT

    [ https://issues.apache.org/jira/browse/ACCUMULO-3214?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14164207#comment-14164207
] 

Josh Elser edited comment on ACCUMULO-3214 at 10/8/14 9:34 PM:
---------------------------------------------------------------

Oh, it's also possible that {{Tables.exists}} is reporting incorrectly that the table doesn't
exist when it does. It does a {{ZooCache.getChildren}} which does have a childrenCache that
could return false positives.

Edit: I'm pretty convinced this is what happened. 3 tservers -- and it happened right when
I started the Shard randomwalk module (and thus the table was created).


was (Author: elserj):
Oh, it's also possible that {{Tables.exists}} is reporting incorrectly that the table doesn't
exist when it does. It does a {{ZooCache.getChildren}} which does have a childrenCache that
could return false positives.

> NPE checking if replication is enabled during tablet assignment
> ---------------------------------------------------------------
>
>                 Key: ACCUMULO-3214
>                 URL: https://issues.apache.org/jira/browse/ACCUMULO-3214
>             Project: Accumulo
>          Issue Type: Bug
>          Components: replication, tserver
>            Reporter: Josh Elser
>            Assignee: Josh Elser
>            Priority: Minor
>             Fix For: 1.7.0
>
>
> In the Tablet constructor, the generated AccumuloConfiguration happened to be null
> {noformat}
> 2014-10-08 13:43:08,550 [tserver.TabletServer] WARN : exception trying to assign tablet
2y<< hdfs://node1.example.com:8020/apps/accumulo/tables/2y/default_tablet
> java.lang.NullPointerException
>         at org.apache.accumulo.core.replication.ReplicationConfigurationUtil.isEnabled(ReplicationConfigurationUtil.java:39)
>         at org.apache.accumulo.tserver.Tablet.<init>(Tablet.java:1285)
>         at org.apache.accumulo.tserver.Tablet.<init>(Tablet.java:1264)
>         at org.apache.accumulo.tserver.Tablet.<init>(Tablet.java:1120)
>         at org.apache.accumulo.tserver.Tablet.<init>(Tablet.java:1097)
>         at org.apache.accumulo.tserver.TabletServer$AssignmentHandler.run(TabletServer.java:2932)
>         at org.apache.accumulo.core.util.LoggingRunnable.run(LoggingRunnable.java:34)
>         at org.apache.accumulo.trace.instrument.TraceRunnable.run(TraceRunnable.java:47)
>         at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
>         at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
>         at org.apache.accumulo.trace.instrument.TraceRunnable.run(TraceRunnable.java:47)
>         at org.apache.accumulo.core.util.LoggingRunnable.run(LoggingRunnable.java:34)
>         at java.lang.Thread.run(Thread.java:745)
> {noformat}



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message