accumulo-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Josh Elser (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (ACCUMULO-3122) Rename per-table custom tag property prefix
Date Sun, 14 Sep 2014 21:02:34 GMT

    [ https://issues.apache.org/jira/browse/ACCUMULO-3122?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14133380#comment-14133380
] 

Josh Elser commented on ACCUMULO-3122:
--------------------------------------

I guess I'm having a hard time understanding why they need a special name at all. Users could
have already provided their own custom properties (by re-using a valid prefix that already
exists), this is just providing some "standard" convention to say "put all your properties
'here'". Alternatively, these properties could also be thought of as non-server properties.

I think "user" itself could be used, but that might some confusion with our internal notion
of Accumulo users. I dunno, It just feels like "tag' is a bit of a reach instead of something
that is self-describing and doesn't need extra documentation to describe what it does and
why it exists.

> Rename per-table custom tag property prefix
> -------------------------------------------
>
>                 Key: ACCUMULO-3122
>                 URL: https://issues.apache.org/jira/browse/ACCUMULO-3122
>             Project: Accumulo
>          Issue Type: Sub-task
>          Components: client
>            Reporter: Christopher Tubbs
>            Priority: Trivial
>              Labels: api, docuentation, naming
>             Fix For: 1.7.0
>
>
> I'm not 100% sold on the name of the {{table.custom.\*}} prefix added in ACCUMULO-2841.
I think a better name might be {{table.tag.\*}} or similar, and I'm leaning towards that.
*Tag* might be better vocabulary to use, especially when discussing the feature in the documentation,
and the property prefix name should be consistent with how we refer to the feature.
> I'm creating this issue to provide a forum for property name suggestions/informal votes/comments,
so the name can be solidified before the feature manifests in a release. I don't want to change
it to *tag* now, and then tomorrow change it again in favor of a better name.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message