accumulo-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Christopher Tubbs (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (ACCUMULO-3122) Rename per-table custom tag property prefix
Date Sun, 14 Sep 2014 18:54:33 GMT

     [ https://issues.apache.org/jira/browse/ACCUMULO-3122?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Christopher Tubbs updated ACCUMULO-3122:
----------------------------------------
    Description: 
I'm not 100% sold on the name of the {{table.custom.\*}} prefix added in ACCUMULO-2841. I
think a better name might be {{table.tag.\*}} or similar, and I'm leaning towards that. *Tag*
might be better vocabulary to use, especially when discussing the feature in the documentation,
and the property prefix name should be consistent with how we refer to the feature.

I'm creating this issue to provide a forum for property name suggestions/informal votes/comments,
so the name can be solidified before the feature manifests in a release. I don't want to change
it to *tag* now, and then tomorrow change it again in favor of a better name.

  was:
I'm not 100% sold on the name of the "table.custom.*" prefix added in ACCUMULO-2841. I think
a better name might be "table.tag.*" or similar, and I'm leaning towards that. "Tag" might
be better vocabulary to use, especially when discussing the feature in the documentation,
and the property prefix name should be consistent with how we refer to the feature.

I'm creating this issue to provide a forum for property name suggestions/informal votes/comments,
so the name can be solidified before the feature manifests in a release. I don't want to change
it to "tag" now, and then tomorrow change it again in favor of a better name.


> Rename per-table custom tag property prefix
> -------------------------------------------
>
>                 Key: ACCUMULO-3122
>                 URL: https://issues.apache.org/jira/browse/ACCUMULO-3122
>             Project: Accumulo
>          Issue Type: Sub-task
>          Components: client
>            Reporter: Christopher Tubbs
>            Priority: Trivial
>              Labels: api, docuentation, naming
>             Fix For: 1.7.0
>
>
> I'm not 100% sold on the name of the {{table.custom.\*}} prefix added in ACCUMULO-2841.
I think a better name might be {{table.tag.\*}} or similar, and I'm leaning towards that.
*Tag* might be better vocabulary to use, especially when discussing the feature in the documentation,
and the property prefix name should be consistent with how we refer to the feature.
> I'm creating this issue to provide a forum for property name suggestions/informal votes/comments,
so the name can be solidified before the feature manifests in a release. I don't want to change
it to *tag* now, and then tomorrow change it again in favor of a better name.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message