accumulo-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Josh Elser (JIRA)" <>
Subject [jira] [Commented] (ACCUMULO-3107) Return Map of properties instead of Iterable
Date Wed, 10 Sep 2014 20:58:33 GMT


Josh Elser commented on ACCUMULO-3107:

Where (all) are you proposing these changes be made? TableOperations, NamespaceOperations...
anything else?

Totally agree with you. I can't see any argument to returning an Iterable here. We already
have a Map instantiated from the Thrift RPC. We should just pass that along.

> Return Map of properties instead of Iterable
> --------------------------------------------
>                 Key: ACCUMULO-3107
>                 URL:
>             Project: Accumulo
>          Issue Type: Improvement
>            Reporter: Jenna Huston
> Currently there is only a method to return an Iterable of the properties.  The Map of
properties should be returned to the user instead.

This message was sent by Atlassian JIRA

View raw message