accumulo-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Christopher Tubbs (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (ACCUMULO-3107) Return Map of properties instead of Iterable
Date Fri, 12 Sep 2014 03:31:34 GMT

    [ https://issues.apache.org/jira/browse/ACCUMULO-3107?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14131066#comment-14131066
] 

Christopher Tubbs commented on ACCUMULO-3107:
---------------------------------------------

No, you're right. One isn't bloat. It's when these one-offs get repeated, or becomes a precedent.
That's all I'm suggesting we avoid.

It also gets a bit confusing, because the methods will only differ by return type, so they'll
have to be named differently (getProperties vs. getPropertyMap(?)). This appears (at least
to me) more bloated than, say, overloaded methods with the same name.

> Return Map of properties instead of Iterable
> --------------------------------------------
>
>                 Key: ACCUMULO-3107
>                 URL: https://issues.apache.org/jira/browse/ACCUMULO-3107
>             Project: Accumulo
>          Issue Type: Improvement
>            Reporter: Jenna Huston
>
> Currently there is only a method to return an Iterable of the properties.  The Map of
properties should be returned to the user instead.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message