accumulo-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bill Havanki (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (ACCUMULO-2946) refactor namespace / table operations code to share more code
Date Tue, 24 Jun 2014 16:08:25 GMT

     [ https://issues.apache.org/jira/browse/ACCUMULO-2946?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Bill Havanki updated ACCUMULO-2946:
-----------------------------------

    Summary: refactor namespace / table operations code to share more code  (was: refactor
namespace / table configuration to share more code)

> refactor namespace / table operations code to share more code
> -------------------------------------------------------------
>
>                 Key: ACCUMULO-2946
>                 URL: https://issues.apache.org/jira/browse/ACCUMULO-2946
>             Project: Accumulo
>          Issue Type: Improvement
>          Components: client
>            Reporter: Adam Fuchs
>            Priority: Trivial
>             Fix For: 1.7.0
>
>
> o.a.a.core.client.admin.NamespaceOperationsHelper and o.a.a.core.client.admin.TableOperationsHelper
have a lot of repeated code between them. Refactor them to remove the duplication. Maybe this
could be done by adding a boolean to the method signatures, representing whether we're configuring
a namespace or a table?



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message