accumulo-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Adam Fuchs (JIRA)" <j...@apache.org>
Subject [jira] [Created] (ACCUMULO-2946) refactor namespace / table configuration to share more code
Date Tue, 24 Jun 2014 15:58:25 GMT
Adam Fuchs created ACCUMULO-2946:
------------------------------------

             Summary: refactor namespace / table configuration to share more code
                 Key: ACCUMULO-2946
                 URL: https://issues.apache.org/jira/browse/ACCUMULO-2946
             Project: Accumulo
          Issue Type: Improvement
          Components: client
            Reporter: Adam Fuchs
            Priority: Trivial
             Fix For: 1.7.0


o.a.a.core.client.admin.NamespaceOperationsHelper and o.a.a.core.client.admin.TableOperationsHelper
have a lot of repeated code between them. Refactor them to remove the duplication. Maybe this
could be done by adding a boolean to the method signatures, representing whether we're configuring
a namespace or a table?



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message