accumulo-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Christopher Tubbs (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (ACCUMULO-2934) Use Jetty 8 for 1.6.x
Date Tue, 24 Jun 2014 17:07:26 GMT

    [ https://issues.apache.org/jira/browse/ACCUMULO-2934?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14042378#comment-14042378
] 

Christopher Tubbs commented on ACCUMULO-2934:
---------------------------------------------

One strange thing that I noticed was that I had to add java-continuation as a runtime dependency
to resolve a ClassNotFoundException. That package is available for Jetty 9, but I have not
seen the same issue in Jetty 9. I'm not sure why that's different, but it's something to be
on the lookout for, in case the issue appears in Jetty 9 (it's a pretty easy fix if it does).
I also noticed that jetty-http was needed at the compile scope for Jetty 8 (I think it's because
we were using some HttpBuffer subclass). In Jetty 9, a runtime dependency is sufficient.

> Use Jetty 8 for 1.6.x
> ---------------------
>
>                 Key: ACCUMULO-2934
>                 URL: https://issues.apache.org/jira/browse/ACCUMULO-2934
>             Project: Accumulo
>          Issue Type: Sub-task
>          Components: monitor
>            Reporter: Christopher Tubbs
>            Assignee: Christopher Tubbs
>            Priority: Blocker
>             Fix For: 1.6.1
>
>          Time Spent: 0.5h
>  Remaining Estimate: 0h
>
> ACCUMULO-2808 inadvertently bumped the minimum supported JRE to 7. This breaks expectations
that come with 1.6.x to support JRE 6.
> If we back off to Jetty 8, we should be able to continue to support JRE 6 for the 1.6.x
versions of Accumulo, and move to an org.eclipse.jetty version that is still supported.
> Jetty 9 can continue to be used for versions after 1.6.x, which require JRE 7 already.



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message