accumulo-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Josh Elser (JIRA)" <j...@apache.org>
Subject [jira] [Comment Edited] (ACCUMULO-2918) replication makes tservers quit
Date Tue, 17 Jun 2014 15:29:03 GMT

    [ https://issues.apache.org/jira/browse/ACCUMULO-2918?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14033903#comment-14033903
] 

Josh Elser edited comment on ACCUMULO-2918 at 6/17/14 3:28 PM:
---------------------------------------------------------------

Can you give more context here of what you did? What does "starting up 1.7.0" mean?

{{accumulo init}} will create the necessary ZK parent nodes. If you overlay new jars (post
replication merge) on top of an existing installation, these parent nodes would not exist
(just as any of the other ZooKeeper nodes wouldn't.

Edit: Can be a little clearer: Yes, if you have an existing 1.7.0-SNAPSHOT installation that
you just update the new jars with without re-initializing, you will get this error. A fresh
1.7.0-SNAPSHOT installation should not see this. Any upgrade code between 1.6.0 and 1.7.0
will also need to do this (do we have this somewhere already?)


was (Author: elserj):
Can you give more context here of what you did? What does "starting up 1.7.0" mean?

{{accumulo init}} will create the necessary ZK parent nodes. If you overlay new jars (post
replication merge) on top of an existing installation, these parent nodes would not exist
(just as any of the other ZooKeeper nodes wouldn't.

> replication makes tservers quit
> -------------------------------
>
>                 Key: ACCUMULO-2918
>                 URL: https://issues.apache.org/jira/browse/ACCUMULO-2918
>             Project: Accumulo
>          Issue Type: Bug
>          Components: replication
>         Environment: starting up 1.7.0 after replication was commited
>            Reporter: Eric Newton
>            Assignee: Josh Elser
>
> replication needs some upgrade code to make some nodes in zookeeper
> Here's the error message:
> {noformat}
> KeeperErrorCode = NoNode for /accumulo/2f3173c3-c02f-4e3a-b01c-7f721d4a9f00/replication/tservers/host:9997
> {noformat}



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message