accumulo-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dave Marion (JIRA)" <j...@apache.org>
Subject [jira] [Comment Edited] (ACCUMULO-2844) Remove master/slave terminology
Date Mon, 02 Jun 2014 19:45:04 GMT

    [ https://issues.apache.org/jira/browse/ACCUMULO-2844?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14015781#comment-14015781
] 

Dave Marion edited comment on ACCUMULO-2844 at 6/2/14 7:44 PM:
---------------------------------------------------------------

In case there was any confusion about where I stand on the issue:

-1 to changing anything in the bug fix branches as the original description does not state
or imply that the changes will maintain api compatibility. Instead it says, "I intend to do
this in all active branches in a way that maintains compatibility of existing configuration
files and serialized actions"
+1 to changing the name of the slaves file in 1.7
-0 to changing the name of the Master process. I don't think it needs to be changed, but agree
its not descriptive. For that matter we could change garbage collector to file collector.

Updated: Added justification for veto.


was (Author: dlmarion):
In case there was any confusion about where I stand on the issue:

-1 to changing anything in the bug fix branches
+1 to changing the name of the slaves file in 1.7
-0 to changing the name of the Master process. I don't think it needs to be changed, but agree
its not descriptive. For that matter we could change garbage collector to file collector.

> Remove master/slave terminology
> -------------------------------
>
>                 Key: ACCUMULO-2844
>                 URL: https://issues.apache.org/jira/browse/ACCUMULO-2844
>             Project: Accumulo
>          Issue Type: Task
>    Affects Versions: 1.5.0, 1.5.1, 1.6.0
>            Reporter: Sean Busbey
>            Assignee: Sean Busbey
>             Fix For: 1.5.2, 1.6.1, 1.7.0
>
>
> I'd like to remove our use of master/slave terminology in favor of something that doesn't
carry a racially charged meaning.
> As a side effect I'd also like to pick names that carry better meaning of how things
work within Accumulo.
> In the case of a single cluster, I'd like to
> * Change the Master role to Coordinator
> * Change the associated master server package to coordinator
> * Change the master configuration file to be named coordinators
> * Change the slaves configuration file to be named tservers
> In the case of the in-progress replication work I'd like to change terminology:
> * use _Primary Cluster_  in place of _Master Cluster_
> * use _Replica Clusters_ in place of _Slave Clusters_
> I intend to do this in all active branches in a way that maintains compatibility of existing
configuration files and serialized actions (i.e. fate operations) within their major branch.
In the current unreleased major branch I expect upgrading will require user action (e.g. renaming
configuration files).



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message