accumulo-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ed Coleman (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (ACCUMULO-2641) scan id not set in org.apache.accumulo.core.client.admin.ActiveScan
Date Fri, 13 Jun 2014 12:46:03 GMT

    [ https://issues.apache.org/jira/browse/ACCUMULO-2641?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14030581#comment-14030581
] 

Ed Coleman commented on ACCUMULO-2641:
--------------------------------------

Last night at the Accumulo Summit, [~kturner] was able to make the changes to the thrift code
to add scanid as an optional argument. I will add a unit test then submit a patch.

> scan id not set in org.apache.accumulo.core.client.admin.ActiveScan
> -------------------------------------------------------------------
>
>                 Key: ACCUMULO-2641
>                 URL: https://issues.apache.org/jira/browse/ACCUMULO-2641
>             Project: Accumulo
>          Issue Type: Bug
>          Components: client
>    Affects Versions: 1.4.4, 1.5.1
>            Reporter: Ed Coleman
>            Assignee: Ed Coleman
>            Priority: Minor
>             Fix For: 1.7.0
>
>
> Trying to profile some long running scans I tried to use the getScanid() method on ActiveScan,
but it always returned 0.
> Looking at the class, it seems that the value is never set.  There is a getter but no
setter and it is not set in the constructor.
> Also, it seems that the scanid is not included in the thrift ActiveScan so a fix will
not be a simple as just setting scanid in the constructor.



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message