accumulo-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Keith Turner (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (ACCUMULO-2844) Remove master/slave terminology
Date Tue, 27 May 2014 19:16:04 GMT

    [ https://issues.apache.org/jira/browse/ACCUMULO-2844?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14010151#comment-14010151
] 

Keith Turner commented on ACCUMULO-2844:
----------------------------------------

This is a good change to make for 1.7.  Making the change in 1.5 and 1.6 seems like it would
require a lot of extra work and testing (that would not be needed in 1.7) in order to ensure
it does not break things for users.  Also as [~bills] mentioned, the old names will still
be present in 1.5 and 1.6 for compatibility reasons.  I really like [~billie.rinaldi] suggestion
for 1.5 and 1.6. 

bq.  It may also be worth evaluating whether "master" is still offensive in the absence of
"slaves".

Renaming the slaves file to tservers will likely not cause users problems and it seems to
solve the problem at hand.   The term master by itself does not seem offensive, its a very
widely used and uncontroversial term.  

While master by itself does not seem offensive, it also is not very accurate.  Common uses
are related to someone who is an expert.  Renaming the slaves files leaves us with something
thats just poorly named.  Engineers often poorly names things.  I really like a lot of the
other names that have been suggested.

 As for renaming things in the master branch and not in 1.5-SNAPSHOT or 1.6-SNAPSHOT, git
handles this really well.

If the change were made in 1.5 and 1.6, would we post two sets of documentation on the web
site?  One for 1.6.0 and one for 1.6.1 using the different terminology?  



> Remove master/slave terminology
> -------------------------------
>
>                 Key: ACCUMULO-2844
>                 URL: https://issues.apache.org/jira/browse/ACCUMULO-2844
>             Project: Accumulo
>          Issue Type: Task
>    Affects Versions: 1.5.0, 1.5.1, 1.6.0
>            Reporter: Sean Busbey
>            Assignee: Sean Busbey
>             Fix For: 1.5.2, 1.6.1, 1.7.0
>
>
> I'd like to remove our use of master/slave terminology in favor of something that doesn't
carry a racially charged meaning.
> As a side effect I'd also like to pick names that carry better meaning of how things
work within Accumulo.
> In the case of a single cluster, I'd like to
> * Change the Master role to Coordinator
> * Change the associated master server package to coordinator
> * Change the master configuration file to be named coordinators
> * Change the slaves configuration file to be named tservers
> In the case of the in-progress replication work I'd like to change terminology:
> * use _Primary Cluster_  in place of _Master Cluster_
> * use _Replica Clusters_ in place of _Slave Clusters_
> I intend to do this in all active branches in a way that maintains compatibility of existing
configuration files and serialized actions (i.e. fate operations) within their major branch.
In the current unreleased major branch I expect upgrading will require user action (e.g. renaming
configuration files).



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message