accumulo-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sean Busbey (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (ACCUMULO-2844) Remove master/slave terminology
Date Tue, 27 May 2014 17:46:07 GMT

    [ https://issues.apache.org/jira/browse/ACCUMULO-2844?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14009958#comment-14009958
] 

Sean Busbey commented on ACCUMULO-2844:
---------------------------------------

{quote}
bq.It may also be worth evaluating whether "master" is still offensive in the absence of "slaves".

This might be a worthwhile discussion given the amount of discussion generated by a similar
change in Django.
{quote}

It really isn't. Listen to the marginalized. Unless someone has a valid technical veto for
this change, pursuing a debate about this will just result in me pushing forward with less
discussion.

> Remove master/slave terminology
> -------------------------------
>
>                 Key: ACCUMULO-2844
>                 URL: https://issues.apache.org/jira/browse/ACCUMULO-2844
>             Project: Accumulo
>          Issue Type: Task
>    Affects Versions: 1.5.0, 1.5.1, 1.6.0
>            Reporter: Sean Busbey
>            Assignee: Sean Busbey
>             Fix For: 1.5.2, 1.6.1, 1.7.0
>
>
> I'd like to remove our use of master/slave terminology in favor of something that doesn't
carry a racially charged meaning.
> As a side effect I'd also like to pick names that carry better meaning of how things
work within Accumulo.
> In the case of a single cluster, I'd like to
> * Change the Master role to Coordinator
> * Change the associated master server package to coordinator
> * Change the master configuration file to be named coordinators
> * Change the slaves configuration file to be named tservers
> In the case of the in-progress replication work I'd like to change terminology:
> * use _Primary Cluster_  in place of _Master Cluster_
> * use _Replica Clusters_ in place of _Slave Clusters_
> I intend to do this in all active branches in a way that maintains compatibility of existing
configuration files and serialized actions (i.e. fate operations) within their major branch.
In the current unreleased major branch I expect upgrading will require user action (e.g. renaming
configuration files).



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message