accumulo-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Christopher Tubbs (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (ACCUMULO-2786) Jetty / servlet JARs not packaged for monitor
Date Mon, 12 May 2014 20:24:15 GMT

    [ https://issues.apache.org/jira/browse/ACCUMULO-2786?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13995584#comment-13995584
] 

Christopher Tubbs commented on ACCUMULO-2786:
---------------------------------------------

[~fwiffo] wrote:
bq. Apache Hadoop switched to packaging jars...
bq. Including all jars under all subdirectories of a Hadoop tarball pollutes the class path
quite a bit.

Understood and agreed. Further, Accumulo's configuration can be easily modified to include
only the jars which are needed. The default and example "general.classpaths" option pulls
in a lot, and account for these separate 2.0.0+ directories. The default value ensures things
work most easily out of the box a very wide set of circumstances, but a more targeted value
for this option, which doesn't pollute the classpath certainly seems reasonable and appropriate.
You certainly don't need to include all these jars for Accumulo to work. However, I think
that's a slightly different question (how do I configure my classpath?) than the one of which
to package.

> Jetty / servlet JARs not packaged for monitor
> ---------------------------------------------
>
>                 Key: ACCUMULO-2786
>                 URL: https://issues.apache.org/jira/browse/ACCUMULO-2786
>             Project: Accumulo
>          Issue Type: Bug
>          Components: build
>    Affects Versions: 1.6.0
>            Reporter: Bill Havanki
>            Assignee: Christopher Tubbs
>            Priority: Minor
>              Labels: assembly, jetty, package
>         Attachments: ACCUMULO-2786.v1.patch.txt
>
>
> The monitor needs Jetty (and, transitively, the servlet API) to run. The tarball generated
by {{mvn -P assemble package}} does not include Jetty, so an installation needs to get it
from elsewhere.
> ACCUMULO-2301 was the first attempt at fixing this, and it works for 1.4 and 1.5, but
it appears that the change didn't make it to 1.6.
> A workaround is to hand-copy the Jetty and servlet JARs to Accumulo's lib directory,
or add a location where Jetty already exists to the Accumulo classpath.



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message