accumulo-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Keith Turner (JIRA)" <j...@apache.org>
Subject [jira] [Created] (ACCUMULO-2749) 1.6.0RC4 slower than 1.5.1
Date Mon, 28 Apr 2014 22:47:15 GMT
Keith Turner created ACCUMULO-2749:
--------------------------------------

             Summary: 1.6.0RC4 slower than 1.5.1
                 Key: ACCUMULO-2749
                 URL: https://issues.apache.org/jira/browse/ACCUMULO-2749
             Project: Accumulo
          Issue Type: Bug
    Affects Versions: 1.6.0
            Reporter: Keith Turner
             Fix For: 1.6.1


I am seeing consistently slower write rates when comparing 1.5.1 and 1.6.0 RC4.   Following
env :

   * hadoop 2.2.0
   * Zookeeper 3.4.5
   * Centos 6 (native, not a VM)
   * using examples/3GB/native-standalone config
   * setting tserver.mutation.queue.max 4M
   * I am running test/system/test1/ingest_test.sh
   * single node

Saw the following rates

{noformat}
  1.5.1 aggregate rate : 200,806 records/sec
  1.6.0 aggregate rate : 181,264 records/sec (90%)
{noformat}

Reran test setting  table.walog.enabled=false

{noformat}
  1.5.1 aggregate rate : 302,307 records/sec
  1.6.0 aggregate rate : 232,685 records/sec (77%)
{noformat}

Since the relative performance gap seemed to widen when disabling walog I tried another test
where I disabled walogs and set the devnull iterator 

{noformat}
  1.5.1 aggregate rate : 554,853 records/sec
  1.6.0 aggregate rate : 373,556 records/sec (67%)
{noformat}

The relative performance gap grew even further.

Used the following command to enable dev null iterator in 1.5.1 and RC4

{noformat}
config -t test_ingest -s table.iterator.minc.devnull=10,org.apache.accumulo.core.iterators.DevNull
{noformat}



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message