accumulo-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Josh Elser (JIRA)" <j...@apache.org>
Subject [jira] [Comment Edited] (ACCUMULO-2586) RangeInputSplit package name changed
Date Fri, 11 Apr 2014 03:32:16 GMT

    [ https://issues.apache.org/jira/browse/ACCUMULO-2586?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13966176#comment-13966176
] 

Josh Elser edited comment on ACCUMULO-2586 at 4/11/14 3:31 AM:
---------------------------------------------------------------

Looks like the problem goes even deeper than just this. In merging the fix to make 1.5 correct,
1.6.0 the AccumuloMultiTableInputFormat also broke compatibility by changing the {{String,
Range, String[]}} constructor to {{String, String, Range, String[]}}.

Edit: Oops, Keith did catch that in ACCUMULO-2659. I'll let that be fixed there rather than
here.


was (Author: elserj):
Looks like the problem goes even deeper than just this. In merging the fix to make 1.5 correct,
1.6.0 the AccumuloMultiTableInputFormat also broke compatibility by changing the {{String,
Range, String[]}} constructor to {{String, String, Range, String[]}}.

> RangeInputSplit package name changed
> ------------------------------------
>
>                 Key: ACCUMULO-2586
>                 URL: https://issues.apache.org/jira/browse/ACCUMULO-2586
>             Project: Accumulo
>          Issue Type: Bug
>    Affects Versions: 1.5.1
>            Reporter: Josh Elser
>            Assignee: Josh Elser
>            Priority: Minor
>             Fix For: 1.5.2, 1.6.0
>
>         Attachments: 0001-ACCUMULO-2586-Add-in-a-deprecated-RangeInputSplit-to-2.patch,
0001-ACCUMULO-2586-Add-in-a-deprecated-RangeInputSplit-to.patch
>
>
> RangeInputSplit (inner class of InputFormatBase). 1.5.1 release vote had deemed this
class not *actually* a part of the public API and, thus, that the change was OK to make without
the regular deprecation cycles.
> User was using this class directly, because it was public, and had incompatibility between
1.5.0 and 1.5.1.



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message