accumulo-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Josh Elser (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (ACCUMULO-2586) RangeInputSplit package name changed
Date Tue, 01 Apr 2014 18:25:21 GMT

    [ https://issues.apache.org/jira/browse/ACCUMULO-2586?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13956853#comment-13956853
] 

Josh Elser commented on ACCUMULO-2586:
--------------------------------------

Doesn't matter to me. I'd be of the mindset to not change 1.6 from how it is now.

> RangeInputSplit package name changed
> ------------------------------------
>
>                 Key: ACCUMULO-2586
>                 URL: https://issues.apache.org/jira/browse/ACCUMULO-2586
>             Project: Accumulo
>          Issue Type: Bug
>    Affects Versions: 1.5.1
>            Reporter: Josh Elser
>            Assignee: Josh Elser
>            Priority: Minor
>             Fix For: 1.5.2
>
>         Attachments: 0001-ACCUMULO-2586-Add-in-a-deprecated-RangeInputSplit-to-2.patch,
0001-ACCUMULO-2586-Add-in-a-deprecated-RangeInputSplit-to.patch
>
>
> RangeInputSplit (inner class of InputFormatBase). 1.5.1 release vote had deemed this
class not *actually* a part of the public API and, thus, that the change was OK to make without
the regular deprecation cycles.
> User was using this class directly, because it was public, and had incompatibility between
1.5.0 and 1.5.1.



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message