accumulo-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mike Drob (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (ACCUMULO-2586) RangeInputSplit package name changed
Date Tue, 01 Apr 2014 18:21:22 GMT

    [ https://issues.apache.org/jira/browse/ACCUMULO-2586?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13956847#comment-13956847
] 

Mike Drob commented on ACCUMULO-2586:
-------------------------------------

Do any of these changes propagate up to 1.6 or will that be a {{--strategy ours}} merge?

> RangeInputSplit package name changed
> ------------------------------------
>
>                 Key: ACCUMULO-2586
>                 URL: https://issues.apache.org/jira/browse/ACCUMULO-2586
>             Project: Accumulo
>          Issue Type: Bug
>    Affects Versions: 1.5.1
>            Reporter: Josh Elser
>            Assignee: Josh Elser
>            Priority: Minor
>             Fix For: 1.5.2
>
>         Attachments: 0001-ACCUMULO-2586-Add-in-a-deprecated-RangeInputSplit-to-2.patch,
0001-ACCUMULO-2586-Add-in-a-deprecated-RangeInputSplit-to.patch
>
>
> RangeInputSplit (inner class of InputFormatBase). 1.5.1 release vote had deemed this
class not *actually* a part of the public API and, thus, that the change was OK to make without
the regular deprecation cycles.
> User was using this class directly, because it was public, and had incompatibility between
1.5.0 and 1.5.1.



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message