accumulo-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Christopher Tubbs (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (ACCUMULO-1499) Move sanity checks from MiniAccumuloCluster constructor into MiniAccumuloConfig.initialize method.
Date Mon, 28 Apr 2014 19:08:17 GMT

     [ https://issues.apache.org/jira/browse/ACCUMULO-1499?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Christopher Tubbs updated ACCUMULO-1499:
----------------------------------------

    Affects Version/s:     (was: 1.6.0)

> Move sanity checks from MiniAccumuloCluster constructor into MiniAccumuloConfig.initialize
method.
> --------------------------------------------------------------------------------------------------
>
>                 Key: ACCUMULO-1499
>                 URL: https://issues.apache.org/jira/browse/ACCUMULO-1499
>             Project: Accumulo
>          Issue Type: Improvement
>            Reporter: David Medinets
>            Assignee: Miguel Pereira
>            Priority: Trivial
>             Fix For: 1.6.0
>
>         Attachments: ACCUMULO-1499.patch
>
>
> The code below seems like it should be in the config class:
>     if (config.getDir().exists() && !config.getDir().isDirectory())
>       throw new IllegalArgumentException("Must pass in directory, " + config.getDir()
+ " is a file");
>     if (config.getDir().exists() && config.getDir().list().length != 0)
>       throw new IllegalArgumentException("Directory " + config.getDir() + " is not empty");
>     this.config = config.initialize();
> Any objections to this change?



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message