accumulo-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Josh Elser (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (ACCUMULO-2586) RangeInputSplit package name changed
Date Sun, 30 Mar 2014 18:02:14 GMT

     [ https://issues.apache.org/jira/browse/ACCUMULO-2586?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Josh Elser updated ACCUMULO-2586:
---------------------------------

    Attachment: 0001-ACCUMULO-2586-Add-in-a-deprecated-RangeInputSplit-to.patch

Patch that replaces a (deprecated) RangeInputSplit inside of both InputFormatBase classes
which should reintroduce source compatibility against 1.5.0.

> RangeInputSplit package name changed
> ------------------------------------
>
>                 Key: ACCUMULO-2586
>                 URL: https://issues.apache.org/jira/browse/ACCUMULO-2586
>             Project: Accumulo
>          Issue Type: Bug
>    Affects Versions: 1.5.1
>            Reporter: Josh Elser
>            Assignee: Josh Elser
>            Priority: Minor
>             Fix For: 1.5.2
>
>         Attachments: 0001-ACCUMULO-2586-Add-in-a-deprecated-RangeInputSplit-to.patch
>
>
> RangeInputSplit (inner class of InputFormatBase). 1.5.1 release vote had deemed this
class not *actually* a part of the public API and, thus, that the change was OK to make without
the regular deprecation cycles.
> User was using this class directly, because it was public, and had incompatibility between
1.5.0 and 1.5.1.



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message