accumulo-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Keith Turner (JIRA)" <>
Subject [jira] [Commented] (ACCUMULO-2497) InstanceFactory
Date Thu, 20 Mar 2014 16:06:43 GMT


Keith Turner commented on ACCUMULO-2497:

Thanks for the example [~bhavanki], helped me understand what you were thinking.  It seems
liike a useful change.   What do you think about developing code that would use this patch
in tandem?  This patch could be held off until the test that use it are added in another ticket
and both patches pushed at the same time.  If the change is made by itself there is a chance
it will never be used and would be orphaned code from the start.  There is also the possibility
that when you get into the details of writing the test you realize this should work differently.

> InstanceFactory
> ---------------
>                 Key: ACCUMULO-2497
>                 URL:
>             Project: Accumulo
>          Issue Type: Improvement
>          Components: client
>            Reporter: Bill Havanki
>            Assignee: Bill Havanki
>            Priority: Minor
>              Labels: factory, static, testability
>             Fix For: 1.6.1, 1.7.0
> Working on ACCUMULO-2470 (unit tests for server/base) is made difficult by the heavy
dependence on static method calls in our architecture. This ticket is for introducing an {{InstanceFactory}}
interface that will greatly ease testing of code that currently retrieves instances via static
methods (e.g., {{HdfsZooInstance.getInstance()}}).
> Limitations:
> * Work here should be limited to creating {{InstanceFactory}} and its implementations,
and not integrating it into existing code (yet).
> * Work is limited to 1.6 and later. To avoid perturbing the 1.6.0 release no new code
may be introduced into the public API ({{Instance}} is in the public API).
> * A refactoring of the client API is being considered (see ACCUMULO-2128), so this change
should not further complicate - and should hopefully help - that future effort.

This message was sent by Atlassian JIRA

View raw message