accumulo-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF subversion and git services (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (ACCUMULO-2061) Deprecate instance.dfs.uri and instance.dfs.dir
Date Tue, 11 Mar 2014 18:26:00 GMT

    [ https://issues.apache.org/jira/browse/ACCUMULO-2061?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13930715#comment-13930715
] 

ASF subversion and git services commented on ACCUMULO-2061:
-----------------------------------------------------------

Commit 2da21b6a450c474115ad8d9c94747116dccf4017 in accumulo's branch refs/heads/ACCUMULO-2061
from [~elserj]
[ https://git-wip-us.apache.org/repos/asf?p=accumulo.git;h=2da21b6 ]

ACCUMULO-2061 Update FileTypeTest to assert that volumes don't need to have an 'accumulo'
directory


> Deprecate instance.dfs.uri and instance.dfs.dir
> -----------------------------------------------
>
>                 Key: ACCUMULO-2061
>                 URL: https://issues.apache.org/jira/browse/ACCUMULO-2061
>             Project: Accumulo
>          Issue Type: Sub-task
>          Components: master, tserver
>            Reporter: Christopher Tubbs
>            Assignee: Josh Elser
>            Priority: Critical
>             Fix For: 1.6.0
>
>
> {{instance.dfs.uri}} and {{instance.dfs.dir}} are no longer needed with the {{instance.volumes}}
property.
> Together, these two fields are needed for upgrades from relative paths, but full URIs
for volumes should be specified in the {{instance.volumes}} set.
> Instead of appending {{instance.dfs.dir}} to every volume, which is a bit confusing,
they should be specified explicitly in the {{instance.volumes}}.
> Example:
> {code}
>  <property>
>     <name>instance.volumes</name>
>     <value>hdfs://nn1/accumulo</value>
>   </property>
> {code}
> should be equivalent to
> {code}
>  <property>
>     <name>instance.dfs.uri</name>
>     <value>hdfs://nn1</value>
>   </property>
>  <property>
>     <name>instance.dfs.dir</name>
>     <value>/accumulo</value>
>   </property>
> {code}
> This change simplifies the semantics of configuring volumes for Accumulo to use for storage,
and is a bit more obvious that we're logically configuring filesystem volumes, not "namenode
URIs".



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message