accumulo-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Christopher Tubbs (JIRA)" <j...@apache.org>
Subject [jira] [Reopened] (ACCUMULO-2061) Deprecate instance.dfs.uri and instance.dfs.dir
Date Fri, 21 Mar 2014 19:33:43 GMT

     [ https://issues.apache.org/jira/browse/ACCUMULO-2061?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Christopher Tubbs reopened ACCUMULO-2061:
-----------------------------------------


The previous patch introduced a ton of new deprecation warnings for using the newly deprecated
properties. Those warnings need to be dealt with, preferably by isolating the code which accesses
them to a utility method, with a using a single suppression.

If necessary, we could make a new ticket. I was going to make a sub-task, rather than reopen
this one, but this is already a sub-task.

> Deprecate instance.dfs.uri and instance.dfs.dir
> -----------------------------------------------
>
>                 Key: ACCUMULO-2061
>                 URL: https://issues.apache.org/jira/browse/ACCUMULO-2061
>             Project: Accumulo
>          Issue Type: Sub-task
>          Components: master, tserver
>            Reporter: Christopher Tubbs
>            Assignee: Josh Elser
>            Priority: Critical
>             Fix For: 1.6.0
>
>
> {{instance.dfs.uri}} and {{instance.dfs.dir}} are no longer needed with the {{instance.volumes}}
property.
> Together, these two fields are needed for upgrades from relative paths, but full URIs
for volumes should be specified in the {{instance.volumes}} set.
> Instead of appending {{instance.dfs.dir}} to every volume, which is a bit confusing,
they should be specified explicitly in the {{instance.volumes}}.
> Example:
> {code}
>  <property>
>     <name>instance.volumes</name>
>     <value>hdfs://nn1/accumulo</value>
>   </property>
> {code}
> should be equivalent to
> {code}
>  <property>
>     <name>instance.dfs.uri</name>
>     <value>hdfs://nn1</value>
>   </property>
>  <property>
>     <name>instance.dfs.dir</name>
>     <value>/accumulo</value>
>   </property>
> {code}
> This change simplifies the semantics of configuring volumes for Accumulo to use for storage,
and is a bit more obvious that we're logically configuring filesystem volumes, not "namenode
URIs".



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message