accumulo-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Vikram Srivastava (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (ACCUMULO-2373) Daemons should be able to log if log4j.properties specifies sufficient logging
Date Tue, 18 Feb 2014 05:04:19 GMT

    [ https://issues.apache.org/jira/browse/ACCUMULO-2373?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13903782#comment-13903782
] 

Vikram Srivastava commented on ACCUMULO-2373:
---------------------------------------------

bq. The fix for when no matching *_logger.xml is present, we probably don't need to start
the thread which I think would fix the issue your raised.

I think if you do this, log4j would start using the properties file as it did before for logging
and would take care of the other issue as well. So, I'm fine with your proposal.

> Daemons should be able to log if log4j.properties specifies sufficient logging
> ------------------------------------------------------------------------------
>
>                 Key: ACCUMULO-2373
>                 URL: https://issues.apache.org/jira/browse/ACCUMULO-2373
>             Project: Accumulo
>          Issue Type: Bug
>            Reporter: Vikram Srivastava
>         Attachments: log4j.properties
>
>
> Before this commit:
> commit 0351d0d416df51f0b10d91acdc074dced36e40d4
> Author: Josh Elser <elserj@apache.org>
> Date:   Mon Feb 10 23:28:31 2014 -0500
>     ACCUMULO-2334 Remove ACCUMULO_LOG_HOST in favor of pull host and port log-forwarding
from zookeeper
> I was able to do logging with only log4j.properties. However, that doesn't work anymore.
All my daemons have this as the last line of their logs:
> {noformat}
> 2014-02-14 14:23:38,049 INFO org.apache.accumulo.server.Accumulo: Zookeeper connected
and initialized, attemping to talk to HDFS
> 2014-02-14 14:23:38,067 INFO org.apache.accumulo.server.watcher.MonitorLog4jWatcher:
Changing monitor log4j address to 10.20.93.170:4560
> 2014-02-14 14:23:38,067 INFO org.apache.accumulo.server.watcher.MonitorLog4jWatcher:
Enabled log-forwarding
> {noformat}
> Note that I don't use generic_logger.xml, and this wasn't a requirement for 1.4. But
now it seems there is no logging if *_logger.xml files are not present (as ACCUMULO-2349 has
also reported).



--
This message was sent by Atlassian JIRA
(v6.1.5#6160)

Mime
View raw message