accumulo-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF subversion and git services (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (ACCUMULO-2297) Additional unnecessary member on InputFormatBase
Date Fri, 14 Feb 2014 02:19:21 GMT

    [ https://issues.apache.org/jira/browse/ACCUMULO-2297?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13901032#comment-13901032
] 

ASF subversion and git services commented on ACCUMULO-2297:
-----------------------------------------------------------

Commit ec4d4d858ae2ad6aca01f73f2f30a09abd5f0f81 in branch refs/heads/1.6.0-SNAPSHOT from [~elserj]
[ https://git-wip-us.apache.org/repos/asf?p=accumulo.git;h=ec4d4d8 ]

ACCUMULO-2297 Remove unnecessary currentValue and add javadoc for purpose of other members


> Additional unnecessary member on InputFormatBase
> ------------------------------------------------
>
>                 Key: ACCUMULO-2297
>                 URL: https://issues.apache.org/jira/browse/ACCUMULO-2297
>             Project: Accumulo
>          Issue Type: Bug
>          Components: client
>    Affects Versions: 1.4.4, 1.5.0
>            Reporter: Josh Elser
>            Assignee: Josh Elser
>            Priority: Minor
>             Fix For: 1.6.0
>
>
> Noticed in 1.4.5 and 1.5.1 that there's an extra currentValue member defined in the RecordReaderBase
that is never actually used (there's a currentV member that's used instead), conversely to
the currentK and the currentKey members which are returned to the client and used for progress
reporting, respectively.
> We probably shouldn't change these for the current versions (as we could break compilation
across minor releases), but it likely makes sense to remove this extra, unnecessary variable
before 1.6 goes out.



--
This message was sent by Atlassian JIRA
(v6.1.5#6160)

Mime
View raw message