accumulo-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Josh Elser (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (ACCUMULO-2297) Additional unnecessary member on InputFormatBase
Date Mon, 03 Feb 2014 18:36:09 GMT

    [ https://issues.apache.org/jira/browse/ACCUMULO-2297?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13889724#comment-13889724
] 

Josh Elser commented on ACCUMULO-2297:
--------------------------------------

bq. shouldn't we make all the protected Key, K, and Vs in that class private?

Potentially, but that would also cause you to have to write more code with the mapreduce API.
We'd also have to fix our implementations or write some getters (which may be cleaner?).

> Additional unnecessary member on InputFormatBase
> ------------------------------------------------
>
>                 Key: ACCUMULO-2297
>                 URL: https://issues.apache.org/jira/browse/ACCUMULO-2297
>             Project: Accumulo
>          Issue Type: Bug
>          Components: client
>    Affects Versions: 1.4.4, 1.5.0
>            Reporter: Josh Elser
>            Assignee: Josh Elser
>            Priority: Minor
>             Fix For: 1.6.0
>
>
> Noticed in 1.4.5 and 1.5.1 that there's an extra currentValue member defined in the RecordReaderBase
that is never actually used (there's a currentV member that's used instead), conversely to
the currentK and the currentKey members which are returned to the client and used for progress
reporting, respectively.
> We probably shouldn't change these for the current versions (as we could break compilation
across minor releases), but it likely makes sense to remove this extra, unnecessary variable
before 1.6 goes out.



--
This message was sent by Atlassian JIRA
(v6.1.5#6160)

Mime
View raw message