accumulo-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "John Vines (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (ACCUMULO-2297) Additional unnecessary member on InputFormatBase
Date Mon, 03 Feb 2014 17:52:10 GMT

     [ https://issues.apache.org/jira/browse/ACCUMULO-2297?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

John Vines updated ACCUMULO-2297:
---------------------------------

    Fix Version/s:     (was: 1.6.0)
                   1.5.1
                   1.4.5

A. That's a protected value, so I don't see how removing it can affect users
B. It doesn't exist in 1.6.0

> Additional unnecessary member on InputFormatBase
> ------------------------------------------------
>
>                 Key: ACCUMULO-2297
>                 URL: https://issues.apache.org/jira/browse/ACCUMULO-2297
>             Project: Accumulo
>          Issue Type: Bug
>          Components: client
>    Affects Versions: 1.4.4, 1.5.0
>            Reporter: Josh Elser
>            Assignee: Josh Elser
>            Priority: Minor
>             Fix For: 1.4.5, 1.5.1
>
>
> Noticed in 1.4.5 and 1.5.1 that there's an extra currentValue member defined in the RecordReaderBase
that is never actually used (there's a currentV member that's used instead), conversely to
the currentK and the currentKey members which are returned to the client and used for progress
reporting, respectively.
> We probably shouldn't change these for the current versions (as we could break compilation
across minor releases), but it likely makes sense to remove this extra, unnecessary variable
before 1.6 goes out.



--
This message was sent by Atlassian JIRA
(v6.1.5#6160)

Mime
View raw message