accumulo-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sean Busbey (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (ACCUMULO-2148) Verify upgrade 1.5 to 1.6 works
Date Fri, 21 Feb 2014 23:07:19 GMT

    [ https://issues.apache.org/jira/browse/ACCUMULO-2148?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13908965#comment-13908965
] 

Sean Busbey commented on ACCUMULO-2148:
---------------------------------------

I can verify that given a 1.4 instance, 1.6.0-SNAPSHOT properly says "Nooooooope."

The error message is the generic "This version of Accumulo doesn't work with the version from
your data" from server/base/src/main/java/org/apache/accumulo/server/Accumulo.java 

{code}
    if (dataVersion != ServerConstants.DATA_VERSION && dataVersion != ServerConstants.PREV_DATA_VERSION)
{
      throw new RuntimeException("This version of accumulo (" + codeVersion + ") is not compatible
with files stored using data version " + dataVersion);
    }
{code}

Does this upgrade just need to be manual? Would an upgrade from 1.5.1-rc2 be sufficient?

> Verify upgrade 1.5 to 1.6 works
> -------------------------------
>
>                 Key: ACCUMULO-2148
>                 URL: https://issues.apache.org/jira/browse/ACCUMULO-2148
>             Project: Accumulo
>          Issue Type: Task
>            Reporter: Keith Turner
>            Assignee: Keith Turner
>            Priority: Blocker
>             Fix For: 1.6.0
>
>
> Need to verify that 1.6.0 release candidate can upgrade from 1.5.0



--
This message was sent by Atlassian JIRA
(v6.1.5#6160)

Mime
View raw message