accumulo-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Christopher Tubbs (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (ACCUMULO-2061) Deprecate instance.dfs.uri and instance.dfs.dir
Date Wed, 05 Feb 2014 23:06:11 GMT

    [ https://issues.apache.org/jira/browse/ACCUMULO-2061?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13892727#comment-13892727
] 

Christopher Tubbs commented on ACCUMULO-2061:
---------------------------------------------

[~vines]:

Re A: We've done it before (local walogs directory). That's not to say it was necessarily
a great idea, but there is precedent.

Re B: I agree. I think when the tables come online, they should only see absolute paths. I've
voiced this opinion to [~kturner], who has been spending a lot of time on 118. He seemed to
indicate to me that it was easiest to do it when the tablets load and that doing this portion
of the upgrade before things are fully online would add a lot of complexity. I'm not sure
if he'd like to weigh in on the impact of doing that.

> Deprecate instance.dfs.uri and instance.dfs.dir
> -----------------------------------------------
>
>                 Key: ACCUMULO-2061
>                 URL: https://issues.apache.org/jira/browse/ACCUMULO-2061
>             Project: Accumulo
>          Issue Type: Sub-task
>          Components: master, tserver
>            Reporter: Christopher Tubbs
>             Fix For: 1.6.0
>
>
> {{instance.dfs.uri}} and {{instance.dfs.dir}} are no longer needed with the {{instance.volumes}}
property.
> Together, these two fields are needed for upgrades from relative paths, but full URIs
for volumes should be specified in the {{instance.volumes}} set.
> Instead of appending {{instance.dfs.dir}} to every volume, which is a bit confusing,
they should be specified explicitly in the {{instance.volumes}}.
> Example:
> {code}
>  <property>
>     <name>instance.volumes</name>
>     <value>hdfs://nn1/accumulo</value>
>   </property>
> {code}
> should be equivalent to
> {code}
>  <property>
>     <name>instance.dfs.uri</name>
>     <value>hdfs://nn1</value>
>   </property>
>  <property>
>     <name>instance.dfs.dir</name>
>     <value>/accumulo</value>
>   </property>
> {code}
> This change simplifies the semantics of configuring volumes for Accumulo to use for storage,
and is a bit more obvious that we're logically configuring filesystem volumes, not "namenode
URIs".



--
This message was sent by Atlassian JIRA
(v6.1.5#6160)

Mime
View raw message