accumulo-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Josh Elser (JIRA)" <>
Subject [jira] [Commented] (ACCUMULO-2061) Deprecate instance.dfs.uri and instance.dfs.dir
Date Wed, 26 Feb 2014 23:33:19 GMT


Josh Elser commented on ACCUMULO-2061:

[~ctubbsii] that's precisely my concern as well.

In talking to [~kturner], I realized that despite the desire to deprecate the two {{Property}}s,
we're stuck keeping {{instance.dfs.dir}} around because, until we can be absolutely *positive*
that there are no relative paths anywhere, we have to know what the "default" path for a {{FileSystem}}
is. It doesn't make sense to introduce an extra {{Property}} just to do this, so we're stuck
using something internally that we really want to avoid.

To be clear on the self-assignment of this issue, I've started working through some of this,
primarily to avoid {{instance.volumes}} using {{instance.dfs.dir}} when determining where
to write in a {{FileSystem}} (instead using the fully configured Path). I'll be offline for
most of the next week, but I'll try to push up what I have done tonight and will pick it back
up then.

> Deprecate instance.dfs.uri and instance.dfs.dir
> -----------------------------------------------
>                 Key: ACCUMULO-2061
>                 URL:
>             Project: Accumulo
>          Issue Type: Sub-task
>          Components: master, tserver
>            Reporter: Christopher Tubbs
>            Assignee: Josh Elser
>            Priority: Critical
>             Fix For: 1.6.0
> {{instance.dfs.uri}} and {{instance.dfs.dir}} are no longer needed with the {{instance.volumes}}
> Together, these two fields are needed for upgrades from relative paths, but full URIs
for volumes should be specified in the {{instance.volumes}} set.
> Instead of appending {{instance.dfs.dir}} to every volume, which is a bit confusing,
they should be specified explicitly in the {{instance.volumes}}.
> Example:
> {code}
>  <property>
>     <name>instance.volumes</name>
>     <value>hdfs://nn1/accumulo</value>
>   </property>
> {code}
> should be equivalent to
> {code}
>  <property>
>     <name>instance.dfs.uri</name>
>     <value>hdfs://nn1</value>
>   </property>
>  <property>
>     <name>instance.dfs.dir</name>
>     <value>/accumulo</value>
>   </property>
> {code}
> This change simplifies the semantics of configuring volumes for Accumulo to use for storage,
and is a bit more obvious that we're logically configuring filesystem volumes, not "namenode

This message was sent by Atlassian JIRA

View raw message