accumulo-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Keith Turner (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (ACCUMULO-1905) WALog is slow
Date Thu, 27 Feb 2014 23:34:20 GMT

    [ https://issues.apache.org/jira/browse/ACCUMULO-1905?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13915208#comment-13915208
] 

Keith Turner commented on ACCUMULO-1905:
----------------------------------------

Also seeing this issue when testing 1.5.1-RC3.   On a single node hadoop 2.2.0 system I saw
the following approximate aggregate write rates when running test/system/ingest_test.sh. 


|| tserver.mutation.queue.max value || aggregate write rate ||
|| 256K ||  ~40 K mutations/sec ||
|| 1M ||  ~125 K mutations/sec ||
|| 2M ||  ~170 K mutations/sec ||
|| 4M ||  ~200 K mutations/sec ||

This makes me wonder about the 1M default I chose for 1.6.  I was trying to conservative to
avoid introducing memory exhaustion that did not previously exist, but the write rates are
not what I would expect.

> WALog is slow
> -------------
>
>                 Key: ACCUMULO-1905
>                 URL: https://issues.apache.org/jira/browse/ACCUMULO-1905
>             Project: Accumulo
>          Issue Type: Bug
>          Components: tserver
>    Affects Versions: 1.5.0
>         Environment: hadoop 2.2.0, accumulo 1.6.0, hash 45fbee6937549048c74fe176f201c246de0f5e0a
>            Reporter: Eric Newton
>            Assignee: Keith Turner
>            Priority: Critical
>             Fix For: 1.6.0
>
>
> I thought that the continuous ingest test was going slower than it used to.  I was getting
about 20K k-v/sec on my desktop.
> After turning off the WALog, ingest shot up to 200K k-v/sec.  I expected some improvement,
but not an order of magnitude.



--
This message was sent by Atlassian JIRA
(v6.1.5#6160)

Mime
View raw message