accumulo-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Josh Elser (JIRA)" <j...@apache.org>
Subject [jira] [Created] (ACCUMULO-2297) Additional unnecessary member on InputFormatBase
Date Thu, 30 Jan 2014 23:02:11 GMT
Josh Elser created ACCUMULO-2297:
------------------------------------

             Summary: Additional unnecessary member on InputFormatBase
                 Key: ACCUMULO-2297
                 URL: https://issues.apache.org/jira/browse/ACCUMULO-2297
             Project: Accumulo
          Issue Type: Bug
          Components: client
    Affects Versions: 1.5.0, 1.4.4
            Reporter: Josh Elser
            Assignee: Josh Elser
            Priority: Minor
             Fix For: 1.6.0


Noticed in 1.4.5 and 1.5.1 that there's an extra currentValue member defined in the RecordReaderBase
that is never actually used (there's a currentV member that's used instead), conversely to
the currentK and the currentKey members which are returned to the client and used for progress
reporting, respectively.

We probably shouldn't change these for the current versions (as we could break compilation
across minor releases), but it likely makes sense to remove this extra, unnecessary variable
before 1.6 goes out.



--
This message was sent by Atlassian JIRA
(v6.1.5#6160)

Mime
View raw message