accumulo-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Josh Elser (JIRA)" <j...@apache.org>
Subject [jira] [Created] (ACCUMULO-2262) Include java.net.preferIPv4Stack=true in process startup
Date Mon, 27 Jan 2014 19:11:47 GMT
Josh Elser created ACCUMULO-2262:
------------------------------------

             Summary: Include java.net.preferIPv4Stack=true in process startup
                 Key: ACCUMULO-2262
                 URL: https://issues.apache.org/jira/browse/ACCUMULO-2262
             Project: Accumulo
          Issue Type: Improvement
          Components: scripts
    Affects Versions: 1.5.0, 1.4.4
            Reporter: Josh Elser
            Assignee: Josh Elser
             Fix For: 1.4.5, 1.5.1, 1.6.0


I ran into this on a system that didn't have ipv6 disabled. Hadoop started up just fine; however,
Accumulo tried to come up but couldn't communicate to itself.

After some netstat investigation, I realized that it bound to the wrong "localhost". We should
do like Hadoop and include the {{-Djava.net.preferIPv4Stack=true}} java opt when we start
Accumulo processes to make things a bit more resilient. 



--
This message was sent by Atlassian JIRA
(v6.1.5#6160)

Mime
View raw message