accumulo-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF subversion and git services (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (ACCUMULO-2209) Rename DefaultKeyEncryptionStrategy to something more descriptive
Date Fri, 17 Jan 2014 15:25:23 GMT

    [ https://issues.apache.org/jira/browse/ACCUMULO-2209?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13874857#comment-13874857
] 

ASF subversion and git services commented on ACCUMULO-2209:
-----------------------------------------------------------

Commit 75f27e5d17b2b667438b3ca4ecd59e76d0ec206f in branch refs/heads/1.5.1-SNAPSHOT from [~ecn]
[ https://git-wip-us.apache.org/repos/asf?p=accumulo.git;h=75f27e5 ]

ACCUMULO-2209 reset the batch writer on any exception


> Rename DefaultKeyEncryptionStrategy to something more descriptive
> -----------------------------------------------------------------
>
>                 Key: ACCUMULO-2209
>                 URL: https://issues.apache.org/jira/browse/ACCUMULO-2209
>             Project: Accumulo
>          Issue Type: Bug
>          Components: client
>            Reporter: John Vines
>            Assignee: John Vines
>             Fix For: 1.6.0
>
>
> DefaultKeyEncryptionStrategy is used in several places, but for most needs is probably
inferior to CachedHdfsSecretKeyEncryptionStrategy (or whatever it is). We shouldn't be naming
the strategies default as they're not descriptive. We should let the example files define
what is default.



--
This message was sent by Atlassian JIRA
(v6.1.5#6160)

Mime
View raw message