accumulo-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "John Vines (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (ACCUMULO-2209) Rename DefaultKeyEncryptionStrategy to something more descriptive
Date Thu, 16 Jan 2014 22:45:21 GMT

     [ https://issues.apache.org/jira/browse/ACCUMULO-2209?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

John Vines resolved ACCUMULO-2209.
----------------------------------

    Resolution: Fixed

> Rename DefaultKeyEncryptionStrategy to something more descriptive
> -----------------------------------------------------------------
>
>                 Key: ACCUMULO-2209
>                 URL: https://issues.apache.org/jira/browse/ACCUMULO-2209
>             Project: Accumulo
>          Issue Type: Bug
>          Components: client
>            Reporter: John Vines
>            Assignee: John Vines
>             Fix For: 1.6.0
>
>
> DefaultKeyEncryptionStrategy is used in several places, but for most needs is probably
inferior to CachedHdfsSecretKeyEncryptionStrategy (or whatever it is). We shouldn't be naming
the strategies default as they're not descriptive. We should let the example files define
what is default.



--
This message was sent by Atlassian JIRA
(v6.1.5#6160)

Mime
View raw message